Back to overview
Degraded

DDoS Mitigation Provider outage

Oct 02 at 02:10am CEST
Affected services
Amsterdam

Resolved
Oct 02 at 03:39am CEST

Amsterdam recovered. It seems stable again.

Update from our provider:

Good Evening, We are aware of the issues affecting services globally for the last few hours, and have been hard at work. We do know what the issue is, and are in the process of applying remedies to fix it. We should have the situation under control soon, and will provide further updates on this same status post. Thank you for your patience and understanding as we navigate through this current issue.

Created
Oct 02 at 02:10am CEST

There have just been several drops again in Amsterdam due to a bug in our DDoS mitigation provider’s systems. They are aware of the issue and are still working hard on resolving it.