Back to overview
Degraded

Some services are down

Oct 02 at 02:03pm CEST
Affected services
Frankfurt

Resolved
Oct 02 at 02:07pm CEST

Frankfurt recovered. It seems stable again.

Created
Oct 02 at 02:03pm CEST

We are investigation this issue on our Frankfurt location.