Back to overview
Degraded

Massive ongoing attacks

Nov 02 at 02:47pm CET
Affected services
Frankfurt
Amsterdam

Resolved
Nov 02 at 07:49pm CET

It's now stable for a while. We will still continue to monitor it closely.

Updated
Nov 02 at 04:27pm CET

Cosmic has improved; we are hoping this has resolved the issue, but we will continue to monitor it closely.

Created
Nov 02 at 02:47pm CET

Hi all,

CosmicGuard (our DDoS mitigation provider) is currently experiencing large-scale DDoS attacks. They are working on resolving the issue, which may affect the availability of our network.