Back to overview
Resolved

Connections issues

Jul 25, 2026 at 6:37pm UTC
Affected services
Amsterdam

Resolved
Jul 25, 2026 at 6:59pm UTC

The issues are resolved.

Updated
Jul 25, 2026 at 6:43pm UTC

It seems that the situation has been handled but we don't have a official confirm. We are awaiting for the response of Cosmicguard.

Created
Jul 25, 2026 at 6:37pm UTC

There are currently connection issues in Amsterdam if you have a MC or FiveM protection. We are currently looking into the issues.